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Introduction
This is a very simple to use multi-platform Java application which can be used to redirect one of your computer serial
ports and one audio port to Ethernet. In this way you will be able to connect to any serial port (embedded, USB/Serial
modules or Bluetooth modules) remotely over the network and transport audio too with a special client. Some of my
Android applications, are able to serially connect over the Ethernet so this can be a nice addition. PocketRXTX Android
application can use the secure authentication feature to securely connect and control (CAT) your radio transceiver over
Internet, with audio support.

Features
Current version of the application has the following features:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Can be run on Windows, Linux or Mac (with Java Runtime installed)
The application is fully portable, nothing is modified in the Registry and contains only the executable (JAR) and a
simple text configuration file
You can select any local serial port (COMx in Windows, /dev/ttySx or /dev/ttyUSBx in Linux, etc)
You can select Audio In and Audio Out devices from a list. Audio feature is bi-directional, with a mic level meter
for better control;
Display your local IP address
You can set the TCP port which will allow remote connections. Next TCP port is used for audio, if audio
activated.
Configurable Baudrate (from 110 to 921600)
Settings are saved in a configuration file, so no need to enter values again at next start
Auto server start at application startup (unattended)
Auto disconnects if loosing link going back to “wait for connection” mode
PTT can be done over CAT or through RTS or DTR signals, on the same serial port as CAT or a different one
User configurable PTT timeout, in order to prevent locking PTT in Tx when link is broken during transmission
Custom commands/scripts as CAT commands (only with the Pro version of Pocket RxTx)
Monitor mode to help you writing radio config files (monitor data sent/received over serial CAT)
Audio over UDP (lower latency), using the same port number as the one for CAT

IMPORTANT!!!: To keep compatibility with Pocket RxTx, you must respect the following rule. If version is x.y.z-w, to pair
jAReC with Pocket RxTx (Free or Pro), both must have the same x, y and z values in the app version. To find current
version, use Help > About for jAReC or short press on the application name in the startup page for Pocket RxTx.

Limitations
Current version of the application has the following limitations:
•

Cannot be run as a Service as it is (but you can simply do it with extra configuration);

WARNING!!!
Use this application on your own risk. I cannot be held responsible for any damage caused to your
system.
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Starting the application
Windows
To start the application in Windows, if you have previously installed Java Runtime (from Oracle), just click on the file
(jAReC.jar). You will get the following window:

Linux
Using a terminal enter the following command when you are in the folder containing the program:
java –jar jAReC.jar
NOTE: With java runtime version 9, you may get the following error:
ES2 Prism: Error - reported GLX version = 1.2
GLX version 1.3 or higher is required
In this satiation run the application using the following command:
java -Dprism.order=sw -jar jAReC.jar
You will get a window similar withy this one:
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Mac OS
Using a terminal enter the following command when you are in the folder containing the program:
java –jar jAReC.jar
You will get a window similar withy this one:

Note: This application is not yet compatible with Java 9, so please use the latest 8u version. Currently was tested with
Java SE Runtime Environment 8u162 downloaded from here:
http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

Configuring Authentication and Encryption
From the File menu select “Security”. You will get a window similar with this one (on all platforms).

Check to select/unselect authentication. Encryption is not available in the current version, only secure authentication.
Authentication is selected by default. Enter a secret in the white field. This must be a string longer than 3 chars and
cannot contain ‘*’ char. When you are ready click “OK”

Configuring Audio
From the File menu select “Audio”. You will get a window similar with this one (all platforms).
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You need to select Audio In and Audio Out device to point to the audio interface connected to the transceiver.
Check “Use Audio” and press OK.

Configuring Custom Commands
From the File menu select “Custom Cmd”. You will get a window similar with this one (on all platforms):

To add a new custom command, enter the command/script with the full path in the text box, then press “Add”. The
command will be saved using the first available index, ‘02’ in this case. Use this index to assign the command in Pocket
RxTx Pro, as “Command02”.

In this example, when “Command02” is executed by pressing an option button in Pocket RxTx Pro, Notepad is launched
on the PC where jAReC runs.
You can can select from the dropdown box any already saved command and edit it. When you finish the edit, press
“Replace”. Delete selected command by pressing “Delete”. When ready, click “Cancel” to return to the main window.

Using the main application screen
When you hover the mouse over one of the window controls a tooltip will be displayed to better understand the
meaning of that control.
In order to use the application, you need to configure the following parameters:
• Serial port (COMx for Windows, /dev/ttyUSBx / or /dev/ttySx for Linux, tty.usbserial for Mac).
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This will be used for CAT or CAT and PTT if you choose to control PTT through RTS or DTR signals from the same port.
Windows

•

•

•

•

•

Linux

Mac OS

Baudrate. You have the following available values: 110, 300, 600, 1200, 2400, 4800, 9600, 14400, 19200, 38400,
57600, 115200, 128000, 256000, 460800 and 921600. You need to select the same Baudrate as in your
transceiver CAT menu.

TCP Port. This can be any integer value between 1 and 65535. The computer will listen on this port for network
connections to be redirected to the serial interface. If the port is in use, you will get an error message when trying to
start listening.
Note: Please be aware that if you use audio, next TCP port after the one you entered will be used for audio
streaming, so it must be a free one.
PTT Serial port. This is enabled only if you select PTT over RTS or DTR signals. You can select the same serial port as
for CAT or a different one, depending on your specific CAT interface. Many interfaces uses 2 serial ports, one
exclusive for CAT and the other one just for PTT (usually through RTS signal).
PTT Timeout[s]. Here you can enter the timeout for PTT, in seconds. You can enter any integer value between 1 and
65535 seconds. A timer will be started each time you press on PTT. When the time set expire, PTT will be switched
off automatically, even if you continue to keep PTT pressed in Pocket RxTx or the network connection drops.
CAT/RTS/DTR. Set how PTT command is transmitted to the radio: through a CAT command or through a separate
serial port pin (RTS or DTR). If RTS or DTR is selected, you can use respective signals from the same port as for CAT or
a different one.
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After you configure all 3 parameters, click START button to start listening on that port. If the chosen port is free,
then the computer will start listening on that port and the window background will go yellow:
The IP address of the computer will be displayed in the upper part of the window as “MyIP: xxx.xxx.xxx.xxx”
Note: If your computer has multiple IP addresses, only the first one is displayed.
You can now remotely connect to that socket (pair of IP address and TCP port, in the upper example:
192.168.33.2:4444).
The application window background will go yellow when listening for remote connections.

When the remote connection is established successfully, the window background will go green and the remote IP
address will be displayed instead of local IP, as in the following picture:

All the parameters are now saved in the configuration file. If you close and then start again the application, the form will
be automatically filled with the saved parameters, so no need to configure them again.
If you want that the application to automatically go into the listening mode when started, check “Autostart”.
At any time, if you click on STOP button, the connection will be dropped and the window background will go back gray.
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When transmitting (PTT pressed in Pocket RxTx), the background goes red and the microphone level will be shown in a
bar graph, in the lower right part of the window.

A bargraph in the lower part of the screen is used to display audio level. The label change from Spk (for Rx audio level) to
Mic (for Tx audio level).
You can simultaneously start several instances of the application, one for each serial port you want to access through
the network. If you have multiple transceivers, you can start one instance if the application for each of them. The only
requirement is to use different TCP port for each connection, in order to have unique sockets.
Serial Port can be not only a local physical serial port (like COM on the motherboard or USB/Serial interface) but even a
virtual COM port, for example the one created by a Bluetooth interface. You can connect in this way to your Bluetooth
device over the network.

The configuration file
When you first download the application from my web site, there is no configuration file. This is automatically created at
first run, in the same folder as the jar file. You can edit that configuration file using a simple text editor (do not use Word
as it can render the file unusable). The filename is jsn.cfg and the format is the following:
#Wed Sep 21 17:12:29 EET 2016
bUseAuthentication=true
bUseEncryption=false
iPTTtimeout=30
sBaudrate=38400
sPTTport=COM2
bAutostart=false
iPlayInterface=4
PTT=RTS
sCOMport=COM9
bUseAudio=true
iRecInterface=8
sHSecret=2743C71E3828333B277A8FE65050595BF13DD669
nwPort=4444
bRTSpower=true
bDTRpower=false
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Command02=C*/Windows/Notepad.exe
Each parameter is self-explanatory, corresponding with the ones from the GUI. The authentication/encryption password
(secret) is stored as a SHA-1 hash, so you have no way to read it from the configuration file.
For the custom command definition, use “/” instead of “\” when you run jAReC on Windows and replace “:” by “*”.

Setting RTS and/or DTR lines
Some CAT interfaces requires that RTS or DTR line from the COM port to be set. You can do this from the File menu.

Check the line you want to be active. This is saved in the application configuration file.

Using Monitoring mode
From the File menu select “Monitor”. This function is available only when connected from Pocket RxTx (green
background). When in Monitor mode, jAReC does not send any command to the radio. The background goes to cyan, to
show you are in Monitor mode. This mode will help you check and validate CAT commands definition in Pocket RxTx,
including when radio feedback is activated. The monitoring screen looks like in the following image.
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Press one of the option buttons in Pocket RxTx or tune to a specific frequency. Only the last command executed will be
displayed. Let’s take for example manual tuning to 145.225MHz for Yaesu FT-991. By default, the commad is displayed in
HEX format.

For FT-991, default CAT commands definition is based on strings. From the upper dropdown box, you can select display
mode: Hexadecimal, Decimal, Binary or string.

Select String in this case. The command will be displayed accordingly.

You can save the command for future reference. Select from the drop down lists the Brand (Yaesu), the radio model (FT991) and the name of the command “Set frequency to 145.225MHz”, then click on “Save”. This definition will be saved in
the configuration file.
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Next time this command will be received, the parameters are automatically displayed.

To test feedback commands, set in the Pocket RxTx config file for the radio to receive feedback for only one parameter
(ex. Frequency) in POLLING.
POLLING=CMD_READ_FREQ_VFO-A
Now activate feedback for a moment, in order to receive CMD_READ_FREQ_VFO-A command. In the “Read Answer”
text field enter the answer expected from the radio. IN the CAT manual, we have this:

In this case, read command received is ‘FA;’ Let’s consider that the radio return the frequency 3.705MHz. Fill the
expected answer in the second text field and press SET, then activate answer by checking the box.

Now set some other frequency in Pocket RxTx, ex. 145.225MHz and then activate feedback.
You will see how the frequency in Pocket RxTx will be automatically changed to 3.705MHz. In this way you can test one
by one each command that is available for radio feedback.
Monitoring data is saved in a separate configuration file named “mon.cfg”.
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An example is presented below:
#Wed Feb 21 22:50:45 EET 2018
-=Kachina=505DSP
Icom=IC703,IC718,IC746,IC746PRO,IC7000,IC7200,IC7300,IC7400,IC9100,ICR7000ICR71E
Kenwood=TH-F7,TS2000,TS480,TS480SAT,TS480hx,TS570,TS590,TS870
CMD46413134353232353030303B=Yaesu,FT991,Set frequency to 145.225 MHz
;=
TEN-TEC=Orion
CMDFEFEAAE0161201FD=Icom,IC7300,Set AGC Fast
Elecraft=K3,KX3
CMDFEFEAAE0161202FD=Icom,IC7300,Set AGC medium
BRANDS=-,Elecraft,Icom,Kachina,Kenwood,TEN-TEC,Yaesu,Mini
ANS46413B=46413030333730353030303B
Yaesu=FT100,FT1000MP,FT450,FT817,FT847,FT857,FT897,FT950,FT991,FTDX3000,FTDX5000
CMDFEFEAAE0161203FD=Icom,IC7300,Set AGC Slow
Mini=SW2012,SW2012c
Again, the format is self-explanatory. Commands are represented in HEX format.

Application history
Version 0.1 (Feb 27th, 2014). First public release of the application

Version 0.4 (Aug 20th, 2014)
- add secure authentication support - cand be used only with Pocket RXTX Android application as a network client
- add full data encryption support (experimental, buggy)
- add audio support (for the moment only in the GUI, not functional yet)
- detect disconnection and go back to "waiting for connection" mode (yellow background)
Version 0.8 (Aug 23rd, 2015)
- bidirectional audio support with mic level meter
- name changed to jAReC, From (j)ava (A)udio and (Re)mote (Control)
- version number in sync with the Pocket RxTx Android application (for compatible features)
- deactivate START button when already started and STOP button when already stopped.
- changed and bigger icons for security and audio settings
- autostart function added
- reconnect to COM port and restart server if any parameter changed and previously connected
- 128 bytes symmetric key used for password encryption (instead of 64 in the previous version)
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- compatible with Java 8
Version 2.0 (Jan 9th, 2018)
- PTT through CAT, RTS or DTR, on the same as CAT or different COM port
- PTT timer (limit transmission time to prevent locking the transceiver in TX if something happens with the link)
- heartbeat to check at ~8s the link with jAReC and restart listening if link dropped.
- Add RTS/DTR power for the interface (ex for FT-991)
- when in Rx Mode, the bargraph changes from Mic to Spk and diplay Rx audio level
- custom commands/scripts as CAT commands (only with the Pro version of Pocket RxTx)
- Monitor mode to help you writing radio config files (monitor data sent/received over serial CAT)
- audio over UDP (lower latency), using the same port number as the one for CAT
- display all local IP addresses in the main window
Bugs solved:
- if use authentication on jAReC and no auth on Pocket RxTx, CAT does not work but audio is started.
bidirectional audio support with mic level meter
- solve the combo box click bug
- sometimes mic level freezes to the last value even in Rx
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