jarecmini on a raspberry

Here we will discuss any subject related to the Android Pocket Transceiver which is available for free download in Google Play Store
User avatar
yo3ggx
Site Admin
Posts: 650
Joined: Wed Aug 15, 2012 8:30 pm

Re: jarecmini on a raspberry

Post by yo3ggx » Sat Nov 12, 2016 10:23 pm

kd4kso wrote:OK I have that part now. I copied the information to the cfg file. You told me to use jAReCmini. When I try to run the jarecmini file it doesn't see that I have a comm port listed.
jarecmini must display all available audio and serial ports. If the serial port is not in the list, it may be that the port is not visible in java.
Please send the answer from jaremini in the console when is started (with this config file).
When I remove the jsn.cfg file and run it for the first time like the mini manual says it does not create the the file but instead tells me to create one.
You're right. I will correct this in the user guide.

73 Dan YO3GGX

kd4kso
Posts: 13
Joined: Mon Nov 07, 2016 4:30 pm

Re: jarecmini on a raspberry

Post by kd4kso » Sat Nov 12, 2016 10:27 pm

this is what I get when I run the mini file with the jsn file in the same folder. The contents of the mini file are in a previous post and I used the comm port this response suggested.

pi@kd4kso:~/Downloads/jARec $ java -jar jAReCmini_v0.9.0-16.jar
Please set valid Serial port in the jsn.cfg configuration file

Invalid audio device
jAReCmini0.9.0-16
Current settings:
COM Port:
Baudrate: 38400
TCP port: 4444
Use audio: true
Use authentication: true
Secret: 2743C71E3828333B277A8FE65050595BF13DD669
***********

Available com ports:
/dev/ttyAMA0
/dev/ttyUSB0

java.lang.NullPointerException
Available Audio IN devices:
(03) CODEC [plughw:1,0]

java.lang.NullPointerException
Available Audio OUT devices:
(00) ALSA [default]
(01) ALSA [plughw:0,0]
(02) ALSA [plughw:0,1]

If ok, set bAutostart=true in the jsn.cfg file and run again

User avatar
yo3ggx
Site Admin
Posts: 650
Joined: Wed Aug 15, 2012 8:30 pm

Re: jarecmini on a raspberry

Post by yo3ggx » Sat Nov 12, 2016 10:33 pm

It may be a bug in jarecmini 0.9.0-16. I will check this tomorrow and be back.
Unfortunately I don't have a Raspberry Pi to check, but I will do it on a standard linux distribution.

73 Dan YO3GGX

kd4kso
Posts: 13
Joined: Mon Nov 07, 2016 4:30 pm

Re: jarecmini on a raspberry

Post by kd4kso » Sun Nov 13, 2016 1:13 am

Glad to test it out for you

kd4kso
Posts: 13
Joined: Mon Nov 07, 2016 4:30 pm

Re: jarecmini on a raspberry

Post by kd4kso » Mon Nov 14, 2016 1:57 am

I tried this out on a Windows 7 computer and I get the same missing com port. it may be something in my config file.

#Wed Sep 21 17:12:29 EET 2016
bUseAuthentication=true
bUseEncryption=false
iPTTtimeout=30
sBaudrate=38400
sPTTport=COM4
bAutostart=false
iPlayInterface=00
PTT=RTS
sCOMport=COM4
bUseAudio=true
iRecInterface=03
sHSecret=2743C71E3828333B277A8FE65050595BF13DD669
nwPort=4444
bRTSpower=true
bDTRpower=false

User avatar
yo3ggx
Site Admin
Posts: 650
Joined: Wed Aug 15, 2012 8:30 pm

Re: jarecmini on a raspberry

Post by yo3ggx » Mon Nov 14, 2016 9:00 am

You are talking about jarecmini or jAReC on Windows 7?

73 Dan YO3GGX

kd4kso
Posts: 13
Joined: Mon Nov 07, 2016 4:30 pm

Re: jarecmini on a raspberry

Post by kd4kso » Mon Nov 14, 2016 10:03 pm

I got rid of the config file and Ra Jared. It created a new config file and is working. I am going to put that config file on my raspberry pi and test it out. I have it working with my 857 and windows 7 the only problem I have is that the audio is too low. Could that be a problem with my tablet? I need to try it next on my call phone.

Thank you for you patience.
de kd4kso

User avatar
yo3ggx
Site Admin
Posts: 650
Joined: Wed Aug 15, 2012 8:30 pm

Re: jarecmini on a raspberry

Post by yo3ggx » Mon Nov 14, 2016 10:09 pm

Hi.

On the PC side you can control the audio level from the audio mixer (for both in and out). On the Android device you can control only the playback level, the mic level is not user adjustable. When in TX and you speak in the tablet microphone you must see the mic audio level in the bargraph under the memory buttons.

73 Dan YO3GGX

KI6SSI
Posts: 3
Joined: Thu Dec 29, 2016 2:44 am

Re: jarecmini on a raspberry

Post by KI6SSI » Fri Dec 30, 2016 9:16 pm

Hi,

Have it working well here on raspberry pi 3. I can't get the audio out from the usb to work either so I had to use the built in one on the raspberry. I have a Icom IC-718 and home made interface with usb sound card. The PTT is done using a second usb serial port and DTR. Here is my config:

bUseAuthentication=false
bUseEncryption=false
iPTTtimeout=30
sBaudrate=4800
sCATport=/dev/ttyUSB0
sPTTport=/dev/ttyUSB1
bAutostart=true
iPlayInterface=0
PTT=DTR
bRTSpower=false
bUseAudio=true
iRecInterface=3
sHSecret=xxxx
bDTRpower=true
nwPort=22000

And if I remove auto start I get:
jAReC mini version 0.9.0-17
Current settings:
TCP port: 22000
Baudrate: 4800
CAT Port: /dev/ttyUSB0
PTT Port: /dev/ttyUSB0
Use Audio: true
Power over RTS: false
Power over DTR: true
PTT Mode: DTR
Secret Hash: xxx
Audio Out Interface: (0) - ALSA [default]
Audio In Interface: (3) - Device [plughw:1,0]
Use authentication: false
***********
Available com ports:
/dev/ttyAMA0
/dev/ttyUSB0
/dev/ttyUSB1
Available Audio IN devices:
Available Audio OUT devices:
(00) ALSA [default]
(01) ALSA [plughw:0,0]

I used this java:
JAVA_VERSION="1.8.0_06"
OS_NAME="Linux"
OS_VERSION="2.6"
OS_ARCH="arm"
SUN_ARCH_ABI="gnueabihf"

For setting sound levels on the raspberry side on the command line I use the command "alsamixer"

User avatar
yo3ggx
Site Admin
Posts: 650
Joined: Wed Aug 15, 2012 8:30 pm

Re: jarecmini on a raspberry

Post by yo3ggx » Sat Dec 31, 2016 2:28 pm

Hi,

Thank you for your contribution.
KI6SSI wrote:Have it working well here on raspberry pi 3. I can't get the audio out from the usb to work either so I had to use the built in one on the raspberry.
Is the USB audio listed when running the latest jarecmini without a config file?
From the listing below it looks like even the Audio IN is not available (empty data).

73 Dan YO3GGX

Post Reply